태터데스크 관리자

도움말
닫기
적용하기   첫페이지 만들기

태터데스크 메시지

저장하였습니다.

반응형

1. Ruby 설치


루비를 window 시스템에 설치하기 위해서는 루비 공식 홈페이지 다운로드 메뉴에서 최신 버전의  원클릭 인스톨러를 다운 받아 설치하시면 됩니다.


설치는 다운 받은 실행 파일을 더블 클릭한 후 Next 버튼을 눌러 설치 하시면 됩니다.


설치후 CMD 다음과 같이 입력해 줍니다.



 C:\>gem update --system


2. Rails 설치


rails 역시 루비 젬을 통하여 인스톨을 하시면 됩니다.  --include-dependencies 옵션을 사용면 설치시에 레일스가 필요로 하는 모든 라이브러리도 같이 설치하게 됩니다. 해당 구문을 실행해보니 네트웍을 통한 설치라 그런지 상당 시간이 소요 됩니다.


CMD 창에서 다음과 같이 입력하여 rails 를 설치 합니다.


C:\>gem install rails --include-dependencies


3. Mysql 드라이버 설치


데이터 베이스 시스템을 mysql 을 설치하셨다면 mysql 드라이버를 설치하여 줍니다. 루비에는 기본으로 mysql 드라이버가 포함되어 있어 이 과정을 생략해도 무방하다고 합니다.

최적의 성능을 위해서는 최신의 드라이버를 설치해주는 것이 좋습니다.

이것 역시 루베 젬을 통하여 설치합니다. CMD 창에서 아래의 명령어를 입력하시면 됩니다.


 C:\>gem install mysql


위의 명령어를 입력하시면 플랫폼 선택 질의가 나옵니다. windows 시스템에 설치하는 것이니 최신버전의 mswin32 를 선택하여 주시면 됩니다.



위의 과정을 통하여 루비와 레일스를 설치가 완료 되었습니다. 다음 포스트에서는 루비 온 레일스로 웹 서비스를 하는 방법 대하여 설명하도록 하겠습니다.


- 2009.01.16 프미케 -

반응형

Posted by 프미케

댓글을 달아 주세요

  1. 미지의세계 2013.07.04 19:24  댓글주소  수정/삭제  댓글쓰기

    블로그에 설치 방법을 자세하고 이해하기 쉽게 써주셔서 감사합니다.
    따라하는 중에, 에러가 발생했는데, 혹시 방법을 아시는지 여쭈고 싶습니다.
    gem install rails --include-dependencies 를 치면요,
    에러 가 : ERROR: While executing gem ... (OptionParser::InvalidOption)
    invalid option: --include-dependencies 이렇게 뜹니다.

    • BlogIcon 프미케 2013.07.04 20:16 신고  댓글주소  수정/삭제

      일단 어떤 환경에 설치 되었는지 말씀해주셧으면 어떤 조건에서
      에러가 발생을 한것인지 추측하기가 더 좋았을 텐데요
      >c:\ruby\bin\gem --system
      먼저 실행해 주시구여
      >c:\ruby\bin\gem install rails -y
      위의 명령어로 설치해보시면 되실것 같습니다.

  2. 2013.07.04 19:25  댓글주소  수정/삭제  댓글쓰기

    비밀댓글입니다